Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Diagramm dynamisch
#1
Hi,

ich will ein Diagramm mit zwei Datenspalten mit dynamischen Daten erstellen.

Den Datenbereich habe ich als Liste erstellt.

Rekla_WE
ABCDE
1WE_DatumWE_AnzahlReklamationenAnlieferqual. In %Monat
231.01.2007594160,973063973063973Jan 07
328.02.2007526140,973384030418251Feb 07
8531.12.20134230,928571428571429Dez 13
8631.01.20146790,865671641791045Jan 14
8728.02.201464140,78125Feb 14
8831.03.201497110,88659793814433Mrz 14
8930.04.201485190,776470588235294Apr 14
9031.05.201468210,691176470588235Mai 14
9130.06.2014107230,785046728971963Jun 14
9231.07.2014123240,804878048780488Jul 14
9331.08.2014141250,822695035460993Aug 14

verwendete Formeln
Zelle Formel Bereich N/A
A3,A85:A93=WENN(B3<>"";MONATSENDE(A2;1);"")
D2: D3,D85: D93=WENN(C2=0;" ";1-C2/B2)
E2:E3,E85:E93=A2
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 18.12 einschl. 64 Bit

Die Zuweisung der Daten zur Datenreihe mit dieser Zeile geht:
=Rekla_WE!$B$2:$B$93

mit dieser nicht:
=Rekla_WE!INDIREKT("$b2:$b"&ANZAHL2(b:b))
auch so nicht:
=BEREICH.VERSCHIEBEN(Rekla_WE!$A$2;0;0;ANZAHL2(Rekla_WE!$A:$A)-1;1)
oder
=INDIREKT("Tabelle1!A"&ANZAHL(Tabelle1!$A:$A)+2&":A"&ANZAHL(Tabelle1!$A:$A)+2)

Die 93 soll dynamisch werden, was mache ich falsch?
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#2
Hallo Ralf, was ist mit den Zeilen dazwischen..? Ich persönlich arbeite hier immer mit INDEX() - und hierbeibei suche ich die letzte beschriebene Zelle... ... ANZAHL() oder ANZAHL2() ist hier der falsche Weg...!!!
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo Ralf, hier mal für Dein =Rekla_WE!$B$2:$B$93

=Rekla_WE!$B$3:INDEX(Rekla_WE!$B:$B;VERGLEICH(-9^9;Rekla_WE!$B:$B;-1))
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#4
Hi Jörg,

(16.09.2014, 10:45)Jockel schrieb: was ist mit den Zeilen dazwischen..? Ich persönlich arbeite hier immer mit INDEX() - und hierbeibei suche ich die letzte beschriebene Zelle... ... ANZAHL() oder ANZAHL2() ist hier der falsche Weg...!!!

die sind nur für den Beitrag im Forum ausgeblendet.
Ich wollte einfach die benannten Bereiche vermeiden.

Momentan habe ich folgende Lösung:
Spalte_1 = Datum =BEREICH.VERSCHIEBEN('Rekla_WE'!$E$2;0;0;ANZAHL2('Rekla_WE'!$E$1:$E$65536)-1;1)
Spalte_2 = WE_Anzahl =BEREICH.VERSCHIEBEN(Spalte_1;0;-3)
Spalte_3 = Reklaquote =BEREICH.VERSCHIEBEN(Spalte_1;0;-1)

Und dann in den Datenreihen:
=Rekla_WE!Spalte_1
=Rekla_WE!Spalte_2
=Rekla_WE!Spalte_3
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#5
Hallo Ralf, ich meide B.V() wie der Teufel das Weihwasser... ... und ANZAHL2() mag ich in diesem Zusammenhang auch nicht...

Ich denke, ich habe mal wieder eine Anfrage nicht so recht verstanden...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#6
Hi Jörg,

(16.09.2014, 11:08)Jockel schrieb: =Rekla_WE!$B$3:INDEX(Rekla_WE!$B:$B;VERGLEICH(-9^9;Rekla_WE!$B:$B;-1))

wenn ich diese Formel in die Datenreihe eintrage, dann wird ein Fehler in der Formel gemeldet.

Ist $B$3 richtig, wenn die Daten in B2 beginnen?

.xlsb   Auswertung Anlieferqualität.xlsb (Größe: 208,64 KB / Downloads: 4)
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#7
Hallo Ralf,

vielleicht hilft Dir das:

http://www.pc-magazin.de/ratgeber/excel-...51362.html
http://www.herber.de/forum/archiv/1252to...l2010.html
http://www.office-loesung.de/ftopic258001_0_0_asc.php

Auch wenn es Dir evtl. nicht gefällt.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste