Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Diagramm behält Farbgebung nicht bei
#1
Hallo,

ich hoffe hier kann mir jemand helfen. 
Ich habe folgendes Problem:
Ich werte meine Daten mit mehreren Pivottabellen aus. Daraus habe ich jetzt z.B. ein Säulendiagramm erstellt.
Da es auch negative Werte gibt bzw. geben kann, möchte ich dies per "invertieren, wenn negativ" umsetzen.
Hier habe ich jetzt "Grün" für positive und "Rot" für negative Werte ausgewählt. Das Ganze gespeichert, geschlossen und wieder geöffnet.
Nach dem öffnen ist allerdings die Farbgebung für die negative Seite wieder auf "Weiß" zurückgesetzt.

Ich bin ratlos und die Suche im Netz war leider auch erfolglos. Wahrscheinlich ist es wieder nur ein Häkchen, dass ich übersehen habe.

Hier noch das Bild dazu:
http://prnt.sc/ak6h0l

Danke schon mal 

Chris
to top
#2
Moin!
Wenn Du EINMAL auf eine Säule klickst, sie somit ALLE markierst, kannst Du die Invertierung einstellen.
Sie bleibt dann auch erhalten.
Warum verwendest Du kein Pivot-Chart?

   

Gruß Ralf
to top
#3
Hallo Chris

Das ist meines Wissens ein bekannter Bug.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#4
Hi Detlef!
Bei mir (xl2010) klappt es ohne Probleme.

Gruß Ralf
to top
#5
Danke  für die schnellen Antworten! 

@RPP63:
Wie gesagt, die Einstellung habe ich ja gefunden und auch schon komplett auf meine Bedürfnisse eingestellt.
Ausgangssituation ist exakt wie auf deinem Bild. Excel behält sie allerdings nach dem Schließen und wieder Öffnen 
nicht bei.
Ich verwende ja Pivot-Charts. Zumindest bin ich oben auf "Einfügen" > "PivotChart". 

@shift-del:
Ok, das könnte dann einiges erklären. 

Gruß
Chris
to top
#6
Hallo Ralf

Ich habe selber ein Diagramm beim die Invertierungsfarbe definitiv nach speichern und wieder öffnen auf weiß gesetzt wird. Und ich meine auch dass Jon Peltier diesen Bug in einem Blogpost erwähnt hat.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
to top
#7
Ja, Detlef!
Mein Test mit einem "normalen" Chart lief ohne Probleme.
Jetzt habe ich mal ein Pivot-Chart nachgestellt.
Da gibt es tatsächlich dieses Problem! Angry

Insofern: mea culpa!

Gruß Ralf
to top
#8
Danke euch beiden!
Dachte schon, dass ich mal wieder zu doof bin ein Häkchen irgendwo richtig zu setzen.

@RPP63:
Genau so sieht es bei mir auch aus. Aus den "Rohdaten" heraus funktioniert das Bestens. Nur über die "verarbeiteten" Pivot-Daten besteht diese Problem.

In diesem Sinne: Frohe Ostern noch!
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste