Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Diagramm: Reihenwerte abhängig von Zelle
#1
Hallo zusammen,

ich habe eine Frage zur "Automatisierung" eines Diagrammes. Es geht darum, dass ich in einer Excel Datei mehrere Diagramme habe, die jeweils die Daten von 10 Kalenderwochen enthalten. Nun sollen sich aber die Werte der X-Achse und die Daten für die Y-Achse orientieren anhand einer Zahl die in einer anderen Zelle steht.

Also bspw habe ich in Zelle A1 die Zahl 25 für (Kalenderwoche 25) stehen.
Nun sollen die Reihenwerte genommen werden aus einem anderen Tabellenblatt aber mit dem Bereich: ='Auswertung Woche'!$AE$(A1-8):$AE$(A1+1)
Auch die Achsenbeschriftung soll sozusagen "mitwandern", also sprich ='Auswertung Woche'!$A$(A1-8):$A$(A1+1)

Ich möchte nicht, das was allgemein als "dynamische Tabelle" bei der Google suche ausgespuckt wird, also dass Daten hinzukommen und es immer mehr Daten werden und somit das Diagramm verkleinert wird bezogen auf die einzelnen Balken. Ich möchte immer nur die Daten von 10 Zeitpunkten angezeigt kriegen. Also die Werte von den letzten 8 Zeitpunkten, den aktuellen Wert der Kalenderwoche, sowie einen "leeren" Wert für die kommende Woche (sieht im Diagramm besser aus).

Ich hoffe ich konnte mich einigermaßen verständlich ausdrücken.

Vielen Dank im Voraus und beste Grüße

PeterPan
Antwortento top
#2
Hallo

Meine Diagramme sind immer Pivot-Charts.
In Quelldaten füge ich eine Spalte hinzu in der ich ermittle ob der Datensatz innerhalb eines bestimmten Zeitraums liegt (WAHR/FALSCH). Dieses Feld ziehe ich dann in den Filter des Pivot-Chart und filtere auf WAHR.

Auch für Nicht-Pivot-Charts müsste es funktionieren. Das Filtern findet dann eben in der Datentabelle statt.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hi,

(27.06.2016, 10:37)shift-del schrieb: Auch für Nicht-Pivot-Charts müsste es funktionieren. Das Filtern findet dann eben in der Datentabelle statt.

so könnten die x-Werte für das Diagramm ermittelt werden:

Tabelle1
ABCDEFGHIJ
2Anzahl Werte für Anzeige8Also die Werte von den letzten 8 Zeitpunkten, den aktuellen Wert der Kalenderwoche, sowie einen "leeren" Wert für die kommende Woche
3
4DatumKWdpmSummenproduktWENNW / FKW heute - 8KW heute + 1
501.07.20152015/271216,2Falsch262016/182016/28
608.07.20152015/281391,33Falsch
715.07.20152015/291176,73Falsch
822.07.20152015/301129,51Falsch
929.07.20152015/311029,18Falsch
1005.08.20152015/321010Falsch
1112.08.20152015/331238,32Falsch
1219.08.20152015/341059,53Falsch
1326.08.20152015/35781,32Falsch
1402.09.20152015/36902,91Falsch
1509.09.20152015/371192,45Falsch

verwendete Formeln
Zelle Formel Bereich N/A
H5=KALENDERWOCHE(HEUTE();21)
I5=JAHR(HEUTE()) & "/" &(KALENDERWOCHE(HEUTE();21)-D2)
J5=JAHR(HEUTE()) & "/" &(KALENDERWOCHE(HEUTE();21))+2
A6:A15=A5+7
B5:B15=JAHR([@Datum]) & "/" &KALENDERWOCHE(Tabelle1!$A5;21)
D5: D15=WENN(SUMMENPRODUKT((B5>=$I$5)*(B5<=$J$5)*[@dpm])=0;"";SUMMENPRODUKT((B5>=$I$5)*(B5<=$J$5)*[@dpm]))
E5:E15=WENN(UND(B5>=$I$5;B5<$J$5);[@dpm];"")
F5:F15=WENN(UND(B5>=$I$5;B5<$J$5);"WAHR";"Falsch")
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.08 einschl. 64 Bit

Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste