Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datum Feld Aktualisieren
#1
Hallo zusammen,

ich habe eine Ticket Liste erstellt.
Mein Wunsch war, wenn ich irgendeine Ticket Nummer eingebe, sollte Open On Datum Feld automatisch sich aktuellen Tag beziehen. Ansonsten bleibt Datum Feld leer.
Ich habe das Ticket 1234 am 03.06.2015 angelegt.
Dafür habe ich folgende Formel verwendet.
=WENN(ISTLEER(A6);"";D4)
Das Problem ist, wenn ich meine Liste am nächste Tag (04.06.2015) öffne, ändern bzw. aktualisieren sich alle Datum Felder 04.06.2015. Datum für das Ticket 1234 sollte jedoch 03.06.2015 bleiben, wo das Ticket angelegt wurde.
[Bild: 22116612ex.png]
[Bild: 22116607tj.png]
Wie kann ich es realiseren, dass Open On Datum automatisch angelegt aber sich nicht aktualisiert wird?
(Bespiel Excel Datei im Anhang)
Vielen Dank im Voraus


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 10,37 KB / Downloads: 3)
Antwortento top
#2
Hallo, hier  http://www.ms-office-forum.net/forum/sho...p?t=323061 hat jemand ein ganz ähnliches Problem...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#3
Hallo,

bei MOF wurdest du ja schon auf VBA hingewiesen.

Teste mal den folgenden Code im Modul des Tabellenblattes:

Code:
Private Sub Worksheet_Change(ByVal Target As Range)
'Quelle: Ransi
    If Intersect(Target, Range("A5:A10")) Is Nothing Then Exit Sub
    If Target.Count > 1 Then Exit Sub 'Bearbeiten mehrerer Zeilen wird abgefangen
    If Target = "" Then
        Target.Offset(0, 1).ClearContents
        Else:
        Target.Offset(0, 1) = CDate(Format(Now, "dd.mm.yyyy"))
    End If
End Sub

Den Bereich von A5 bis A10 musst du entsprechend anpassen.
Gruß
Peter
Antwortento top
#4
Hallöchen,

mit einer Formel mit Zirkelbezug kann man ein Datum oder eine Zeit auch einfrieren bzw. fixieren Smile Voraussetzung dafür ist, dass die Berechnung von Zirkelbezügen mit einer Iterationszahl 1 aktiviert wird.

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
102.06.201512

ZelleFormel
A1=WENN(B1="";"";WENN(A1="";HEUTE();A1))
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#5
Hallo Peter
es hat leider nicht geklappt.
Kannst du vielleicht die Excel Datei im Anhang anpassen?
Antwortento top
#6
Hallo,

die Datei im Anhang.


Angehängte Dateien
.xlsm   Mappe1_1.xlsm (Größe: 16,18 KB / Downloads: 7)
Gruß
Peter
Antwortento top
#7
Hallo,

wenn ich Dich richtig verstehe, dann soll beim Öffnen der Datei geprüft werden, ob Zelle D4 ein Datum steht,
wenn nicht, dann soll das aktuelle Datum eingetragen werden.

Das ginge mit folgendem Code:


Code:
Private Sub Workbook_Open()
 With Sheets("Tabelle1").Range("D4")
   If Not IsDate(.Value) Then .Value = Date
 End With
End Sub


Der Code gehört in das Codefenster von DiseArbeitsmappe
Gruß Atilla
Antwortento top
#8
Hallo,

Zitat:wenn ich Dich richtig verstehe

dann habe ich das vollkommen missverstanden.
Gruß
Peter
Antwortento top
#9
Hi Peter,

nee, Du hast es richtig verstanden.

Ich habe nur folgendes:


Zitat:Open On

gelesen und, hab ohne genauer hinzusehen, das dann auf das Open Ereignis der Mappe bezogen.

Sorry, und nichts für ungut.
Gruß Atilla
Antwortento top
#10
Hallöchen,
Open On ist eine Überschrift und nicht eine Aktion beim Öffnen Wink Wenn das Ticket in Spalte A am 3.6. angelegt wurde, soll das zugehörige Datum in Spalte B 3.6. festgeschrieben werden.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste