Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datenbankinhalte in Tabelle verweisen
#1
Sehr geehrte Damen und Herren, 
ich habe folgendes Problem: Ich habe 2 Tabellen Tabelle 1 und Tabelle 2. 
Tabelle 1 enthält Felder, welche mit Inhalt aus Tabelle 2 gefüllt werden sollen.
Tabelle 2 enthält eine Kundendatenbank mit Name, Vorname, Adresse etc.

Name|Vorname|Straße|PLZ
N1|V1|S1|P1
N2|V2|S2|P2

In dieser Form die Inhalte stehen Horizontal die zu durchsuchenden Felder sind Vertikal.
Habe was von SVerweis und WVerweis gelesen aber ich weiß nicht wie ich das richtig angehen soll falls das überhaupt der richtige Ansatz ist.

Mein Vorhaben ich will in Tabelle 1 einfach den Namen, Kundennummer etc. (alles einmalig) eingeben und er soll dann die Zeile mit der Kundennummer aus Tabelle 2 raussuchen und diese dann automatisch in Tabelle 1 in die vorhergesehenen Felder mit dem richtigen Inhalt einfügen. Kann mir da jemand behilflich sein oder den richtigen Anstoß geben?

Mit freundlichen Grüßen
Antwortento top
#2
(13.06.2016, 10:49)EmreCabber schrieb: Name|Vorname|Straße|PLZ
N1|V1|S1|P1
N2|V2|S2|P2

Mein Vorhaben ich will in Tabelle 1 einfach den Namen, Kundennummer etc. (alles einmalig) eingeben und er soll dann die Zeile mit der Kundennummer aus Tabelle 2 raussuchen und diese dann automatisch in Tabelle 1 in die vorhergesehenen Felder mit dem richtigen Inhalt einfügen. Kann mir da jemand behilflich sein oder den richtigen Anstoß geben?

füge in beide Tabellen eine zusätzliche Spalte A mit der Kundennummer ein und dann holst Du die Daten der Tabelle 2 mit dem SVERWEIS():

Tabelle1
ABCDE
1Kd-Nr.NameVornameStraßePLZ
2K1N1V1S1P1
3K2N2V2S2P2

verwendete Formeln
Zelle Formel Bereich N/A
B2:E3=SVERWEIS($A2;Tabelle2!$A:$E;SPALTE(B1);0)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.08 einschl. 64 Bit

Antwortento top
#3
Ich danke dir! Hab deine Idee noch mit einem Dropdownfeld optimiert  19
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste