Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datenbank durchsuchen Formel
#1
Hallo,

ich habe mal eine Frage.

Und zwar möchte ich mittels Excel eine Liste von chemischen Inhaltsstoffen mit einer Datenbank abgleichen lassen, um Übereinstimmungen zu finden.
Die Liste der Inhaltsstoffe sollte möglichst in einer Zelle sein können (um sie leichter aus dem Netz kopieren zu können). Die Chemikalien der Datenbank sind jeweils in einzelnen Zellen angeführt.

Könnte mir jemand behilflich sein, wie die dazugehörige Formel aussehen könnte?
Das wäre einfach super lieb :)

Danke im Voraus
Antwortento top
#2
Hi,

ohne nähere Infos ist eine Hilfe leider nicht richtig möglich.

1. Woher kommt die Datenbank? Hast du die Daten in einer XL-Tabelle?


2. Was genau meinst du mit dieser Bedingung?

Zitat:Die Liste der Inhaltsstoffe sollte möglichst in einer Zelle sein können

3. Eine Musterdatei würde hier sicherlich dazu beitragen, dass dein Vorhaben leichter verstanden wird.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hi,

(12.06.2015, 19:22)WillWissen schrieb: 1. Woher kommt die Datenbank? Hast du die Daten in einer XL-Tabelle?

2. Was genau meinst du mit dieser Bedingung?

Zitat:Die Liste der Inhaltsstoffe sollte möglichst in einer Zelle sein können

3. Eine Musterdatei würde hier sicherlich dazu beitragen, dass dein Vorhaben leichter verstanden wird.

ich vermute so:

.xlsb   Inhaltsstoffe vergleichen.xlsb (Größe: 10,06 KB / Downloads: 4)
Antwortento top
#4
Hallo prem,

ich baue mal auf Ralf's Beispiel auf.
Wenn Du die Daten aus dem Netz oder woher auch immer geholt und in eine Zelle eingefügt hast, musst Du die Bestandteile einzeln bewerten. Dazu kannst Du sie z.B. auf einzelne Zellen verteilen. Ich habe hier mit der Funktion "Text in Spalten" aus dem Reiter "Daten" den Text getrennt. Als Trennzeichen habe ich das Komma gewählt. Für den Vergleich habe ich dann eine Zeile tiefer einfach nur gezählt, ob der Text in der Liste enthalten ist. Das könnte man auch in einer "bedingte Formatierung" verarbeiten und die Zelle und/oder den Text bei Treffer einfärben.
Die Funktion GLÄTTEN habe ich drin, weil in dem Beispieltext von Ralf Leerzeichen nach den Kommata waren und damit dann vor dem jeweils folgenden Buchstaben blieben. Die müssen weg, denn in der Datenbank sind die ja auch nicht drin.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFG
2Datenbank:Liste:     
3aacdg  
4b111100
5c      
6d      
7e      
8f      
9g      
10h      

ZelleFormel
B4=ZÄHLENWENN($A$3:$A$10;GLÄTTEN(B3))
C4=ZÄHLENWENN($A$3:$A$10;GLÄTTEN(C3))
D4=ZÄHLENWENN($A$3:$A$10;GLÄTTEN(D3))
E4=ZÄHLENWENN($A$3:$A$10;GLÄTTEN(E3))
F4=ZÄHLENWENN($A$3:$A$10;GLÄTTEN(F3))
G4=ZÄHLENWENN($A$3:$A$10;GLÄTTEN(G3))
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste