Das letzte Clever-Excel-Forum.de - Treffen
fand vom 15. - 17. September 2017 in Friedrichroda /
Thüringen / Region Großer Inselsberg statt.

Daten aus Pivot-Tabelle entnehmen
#1
Hi,

ich habe eine Pivot-Tabelle, bei der ich die Daten nach Kundennummer, Kundenname und Teilenummer gruppiert habe.

Diese Teilenummern sollen in einer anderen Tabelle (Kunden nebeneinander) jeweils pro Kunde untereinander stehen.

Wie kann ich nun die Teilenummern in die Tabelle verknüpfen, damit bei der nächsten Auswertung bei anderer Anzahl der Teilenummern pro Kunde diese in den richtigen Spalten stehen?
Mit SVERWEIS, VERWEIS, INDEX?

Ausschnitt in Heinz Beitrag Spalte D-N
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top
#2
Hi Ralf,

schau dir mal das an, du kennst ja meine Vorliebe für Hilfsspalten



Auswertung
ABCDEFGHIJKLMN
1Kunde 1Kunde 2Kunde 3Kunde 4Kunde 5
24970004975100679527001995980003988800159
3Summe pro TeileNr497005497510055952700269
4KundenummerKundennameTeileNrErgebnis497004597510012952700209
5Kunde 11Kunde 1/110497Kunde 14970004954970060975100549
6Kunde 12Kunde 1/249700549549700479
7Kunde 13Kunde 1/349700459549700339
8Kunde 14Kunde 1/4497006093
9Kunde 15Kunde 1/5497004791
10Kunde 16Kunde 1/6497003391
1110497 Ergebnis20
12Kunde 21Kunde 2/110751Kunde 2751006792
13Kunde 22Kunde 2/2751005591
14Kunde 23Kunde 2/3751001291
15Kunde 24Kunde 2/4751005491
1610751 Ergebnis5
17Kunde 31Kunde 3/110527Kunde 3527001992
18Kunde 32Kunde 3/2527002691in die farbig markierten Felder müssen die TN aus der linken Pivot kopiert werden
19Kunde 33Kunde 3/3527002091
2010527 Ergebnis4
21Kunde 41Kunde 4/110598Kunde 4598000392
2210598 Ergebnis2
23Kunde 51Kunde 5/110888Kunde 5888001591
2410888 Ergebnis1
25Kunde 61Kunde 6/110985Kunde 6410060891
2610985 Ergebnis1
27Gesamtergebnis33

verwendete Formeln
Zelle Formel Bereich N/A
J2:N14=WENNFEHLER(SVERWEIS(J$1&"/"&ZEILE(A1);$C:$G;4;0);"")
C5:C25=A5&WENN(B5="";"";"/")&B5
A5:A27=WENN(F5="";"";WENN(E5<>"";E5;A4))
B5:B27=WENN(A5="";"";ZÄHLENWENN($A$5:A5;A5))
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.24 einschl. 64 Bit

Es ist nicht genug, zu wissen. Man muss es auch anwenden.
Es ist nicht genug, zu wollen. Man muss es auch tun.
[-] Folgende(r) 1 Benutzer sagt Danke an Heinz Ulm für diesen Beitrag:
  • Rabe
to top
#3
Hi Heinz,

(16.06.2014, 14:59)Heinz Ulm schrieb: schau dir mal das an, du kennst ja meine Vorliebe für Hilfsspalten

das sieht sehr gut aus, danke!
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
[-] Folgende(r) 1 Benutzer sagt Danke an Rabe für diesen Beitrag:
  • Heinz Ulm
to top
#4
hallo Ralf, kannst du bitte dein PivotTable noch mal zur verfügung stellen...?
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hi Jörg,

(16.06.2014, 19:33)Jockel schrieb: kannst du bitte dein PivotTable noch mal zur verfügung stellen...?

=> PN
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste