Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Am Sonntag (23.09.) wird das Forum zwischen 06:00 Uhr und 09:00 Uhr kurzzeitig nicht erreichbar sein. Wir stellen auf SSL / HTTPS um.


Dateipfad für Formeln getrennt auflisten
#1
Wink 
Guten Tag,
ich habe folgendes Problem und bin über einen Tipp sehr dankbar:
Da sich die Dateipfade regelmäßig ändern, möchte ich in meinen Formeln anstatt der Dateipfade eine Referenz auf eine Tabelle verwenden.

D.h., konservativ sieht der sverweis wie folgt aus:
=SVERWEIS($B8;'C:\Zahlen\2016\[Zahlen 2016.xlsx]ProduktA'!$A$5:$AA$300;2;FALSCH)

Nun dachte ich, dass ich in einen separaten Reiter (benannt Bezug) 3 Spalten habe, mit:
A1: C:\Zahlen\2016\
B1: Zahlen 2016.xlsx
C1: ProduktA

Des Weiteren dachte ich nun, ich könnte die ehemalige Formel wie folgt anpassen:
=SVERWEIS($B8;'=Bezug!A1[=Bezug!B1]=Bezug!C1'!$A$5:$AA$300;2;FALSCH)

Wenn sich nun Speicherort oder Dateibezeichnung ändert müsste ich nur die Zellen im Reiter "Bezug" anpassen, anstatt in all den Formeln.


Aber: Es funktioniert nicht.
Gibt es für diesen Anwendungsfall eine elegantere Lösung? Konkret konnte ich über die Suchfunktion nichts finden.

Vielen Dank im voraus &
beste Grüße,
Constantin
Antwortento top
#2
Hallo Constantin

Du könntest INDIREKT() verwenden. Allerdings muss dann die Quelldatei geöffnet sein.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hallöchen,

alternativ kannst Du natürlich in einem Rutsch mit Suchen & Ersetzen die Formeln ändern und z.B. aus 2016 2017 machen ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste