Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bezeichnung soll Wert zum Berechnen ergeben
#1
Jaaaa, halloo erstmal...

Wir erstellen unsere Dienstpläne für unsere Studenten immer mit Excel.

Um das Ganze zu vereinfachen, was die Stundenplanung betrifft (um nicht mit dem Taschenrechner daneben zu sitzen), soll die dem Mitarbeiter bekannte Schichtbezeichnung am Ende als Zahlenwert in einem Feld automatisch die Gesamtstunden zusammenrechnen.

Beispiel:
AR5 bezeichnet die Arbeitsschicht und umfasst 5 Stunden, AR 4 Schicht sind dann 4 Stunden etc.  Schichtbezeichnung wird am jew. Arbeitstag beim Mitarbeiter eingetragen und in einem Feld soll dann eine Zusammenfassung der Schichten einfach als Gesamtstunden erscheinen.

Öhhhh... wie gehtn das ?!


Angehängte Dateien
.xlsx   Dienstplanversuch.xlsx (Größe: 6,9 KB / Downloads: 4)
Antwortento top
#2
Hallo, eine Möglichkeit wäre..:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJKLMNOPQ
1MonatJuni
2 MoDiMiDoFrSaSoMoDiMiDoFrSaSoMoStunden
3Name:123456789101112131415
4HerbertAR5AF2AF2 13,5
5Schwörer AR4AR3 8,5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20 AR5AR4AR3AF2AF1
21 54,5445

ZelleFormel
Q4{=SUMME(SUMMEWENN(B4:P4;$B$20:$F$20;$B$21:$F$21))}
Q5{=SUMME(SUMMEWENN(B5:P5;$B$20:$F$20;$B$21:$F$21))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#3
Hallo,

als erste Idee:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNOPQR
1MonatJuni                
2 MoDiMiDoFrSaSoMoDiMiDoFrSaSoMoStunden 
3Name:123456789101112131415  
4HerbertAR5AF2AF2            1313
5SchwörerAR5AR4AR3            13,513,5
19                  
20 AR5AR4AR3AF2AF1  AR55        
21 54,5445  AR44,5        
22        AR34        
23        AF24        
24        AF15        

ZelleFormel
Q4{=SUMMENPRODUKT(($B4:$P4=MTRANS($B$20:$F$20))*(MTRANS($B$21:$F$21)))}
R4=SUMMENPRODUKT(($B4:$P4=$I$20:$I$24)*$J$20:$J$24)
Q5{=SUMMENPRODUKT((B5:P5=MTRANS($B$20:$F$20))*(MTRANS($B$21:$F$21)))}
R5=SUMMENPRODUKT(($B5:$P5=$I$20:$I$24)*$J$20:$J$24)
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#4
(26.05.2015, 15:25)BoskoBiati schrieb: Hallo,

als erste Idee:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJKLMNOPQ
1MonatJuni               
2 MoDiMiDoFrSaSoMoDiMiDoFrSaSoMoStunden
3Name:123456789101112131415 
4HerbertAR5AF2AF2            9
5SchwörerAR5AR4AR3            12,5
19                 
20 AR5AR4AR3AF2AF1           
21 54,5445           

ZelleFormel
Q4{=SUMME(WECHSELN(0&B4:P4;LINKS(0&B4:P4;3);0)*1)+ZÄHLENWENN(B4:P4;"AR4")*0,5}
Q5{=SUMME(WECHSELN(0&B5:P5;LINKS(0&B5:P5;3);0)*1)+ZÄHLENWENN(B5:P5;"AR4")*0,5}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Hallo Edgar, da kommen bei mir aber andere Ergebnisse heraus...
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#5
Hallo Jörg,

habe ich auch gemerkt, bin nach dem Text gegangen:


Zitat:AR5 bezeichnet die Arbeitsschicht und umfasst 5 Stunden, AR 4 Schicht sind dann 4 Stunden etc.

bis ich dann gemerkt habe, dass das ja gar nicht passt.

Ist verbessert.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#6
DANKE !

SUPER ! Vielen Dank ! Es funktioniert perfekt - das spart eine Menge arbeit !
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste