Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bestimmtes Jahr mit Datum vergleichen und Werte ausgeben
#1
Hallo zusammen,

ich habe eine kleine Tabelle (Name | Datum | Code | Bezeichnung | Kostenstelle | Kosten) erstellt. Ich möchte mir die Kosten, gefiltert nach bestimmten Suchkriterien, anzeigen lassen.
Funktioniert auch soweit sehr gut.
Jetzt möchte ich aber zusätzlich ein weiteres Kriterium hinzunehmen: Ich möchte mir zusätzlich zu den schon vorhandenen Kriterien nur Kosten anzeigen lassen, die nur im Jahr X entstanden sind.
Und da verliessen sie mich...ich habe es schon mit Jahr() und Summenprodukt(Jahr()) versucht, bekomme aber kein eindeutiges bzw. ein falsches Ergebnis zurück.
Vielleicht könnt ihr mich erleuchtenSmile

Gruß Wanda


Code:
Alle Kosten für Name Buffi, Code 1, Kostenstelle 410                
=SUMMENPRODUKT(F2:F7;(A2:A7="Buffi")*(C2:C7=1)*(E2:E7=410))
Merken

Merken

Merken
Merken
Merken


Angehängte Dateien
.xlsx   Tierdatenbank.xlsx (Größe: 8,64 KB / Downloads: 5)
Windows 10 - Office 2016 - Diablo 3 ;)
Merken
Merken
Antwortento top
#2
Ungetestet.
Code:
=SUMMENPRODUKT(F2:F7;(A2:A7="Buffi")*(C2:C7=1)*(E2:E7=410)*(JAHR(B2:B7)=X))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Wanda
Antwortento top
#3
Hallo shift-del,

dein Code hat gut funktioniert. Ich hatte eigentlich den gleichen, allerdings ohne genaue Zellangaben.
Code:
'=SUMMENPRODUKT(F:F;(A:A="Buffi")*(C:C=1)*(E:E=410)*(JAHR(B:B)=2013))

Gibt es eine Möglichkeit, das ganze so zu gestalten, dass ich nicht immer die Angaben erweitern muss, sobald ein Datensatz dazukommt?
Gruß, Wanda
Windows 10 - Office 2016 - Diablo 3 ;)
Merken
Merken
Antwortento top
#4
Hallo, ich mag die DB-Funktionen, deshalb hier ein Altenativvorschlag..:

?mage
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Wanda
Antwortento top
#5
(04.07.2016, 21:18)Wanda schrieb: Gibt es eine Möglichkeit, das ganze so zu gestalten, dass ich nicht immer die Angaben erweitern muss, sobald ein Datensatz dazukommt?
Zum einen kann man die Liste als Tabelle formatieren und dann mit strukturierten Verweisen arbeiten.
Zum anderen kann man die Auswertung mit einer Pivot-Tabelle und Datenschnitten machen.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • Wanda
Antwortento top
#6
=SUMMENPRODUKT((A2:INDEX(A:A;ANZAHL2(A:A))="Buffi")*(C2:INDEX(C:C;ANZAHL2(A:A))=1)*(E2:INDEX(E:E;ANZAHL2(A:A))=410)*(JAHR(B2:INDEX(B:B;ANZAHL2(A:A)))=2014);F2:INDEX(F:F;ANZAHL2(A:A)))
[-] Folgende(r) 1 Benutzer sagt Danke an silex1 für diesen Beitrag:
  • Wanda
Antwortento top
#7
Hallo,

ich danke euch vielmals für eure Hilfe, es haben alle Möglichkeiten gut geklappt  28

LG,
Wanda
Windows 10 - Office 2016 - Diablo 3 ;)
Merken
Merken
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste