Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bestellanzahl + Gesamtumsatz je Kunde aus Tabelle
#1
Hallo liebes Excel-Forum,

ich bin bisher nicht sehr vertraut mit den erweiterten Funktionen von Excel 2007 und leider kann ich die allg. Informationen nicht auf mein Thema vollständig anwenden.
Ich hoffe hier mit Eurer Hilfe Lösungen zu meinen Anliegen zu finden und bin für jeden hilfreichen Tipp dankbar.

Ausgangssituation:

Kundenname / Bestellnummer / Bestellwert /  Kanal
Kunde1         / O3321           / 250,00 Euro / FilialeA
Kunde2         / O5467           / 100,00 Euro / Filiale B
Kunde3         / O9344           / 25,00 Euro /   Filiale A
Kunde1         / O8223           / 40,00 Euro /    Filiale A
Kunde3         / O9143           / 75,00 Euro /   Filiale B
Kunde1         / O8453           / 25,00 Euro /   Filiale A
...usw.

Vorhaben:

Anhand der Tabelle zu den Kundenbestellungen möchte ich nun in einem neuen Tabellenblatt die die folgenden Daten darstellen und auswerten können:
Da die Liste künftig mehr als 1000 Datensätze beinhalten wird, möchte ich die folgenden Daten anhand der Ausgangstabelle erstellen, jedoch ohne jeden Kunden Manuell auswählen zu müssen.

Kundenname /Gesamtbestellanzahl pro Kunde / Gesamtbestellwert pro Kunde
Kunde1         / 3                                              / 315,00
Kunde2         / 1                                              / 100,00
...usw

Ich nutze Excel 2007 und kann nicht mit der APPARATFUNKTION arbeiten.

Ich hoffe ich habe mich trotz leihenhafter Ausdrucksweise verständlich ausgedrückt.
Vielen Dank im Vorfeld für Eure Mühen.
Antwortento top
#2
Hallo,

ich würde das mit einer Pivottabelle machen.

Eine Zelle der Datentabelle markieren - Einfügen - Pivottable und dem Assistenten folgen.

Ziehe das Feld Kundenname in die Zeilenbeschriftung und das Feld Bestellwert zweimal in das Wertefeld.

Markiere eine Zelle im Wertefeld - rechte Maus - Werte zusammenfassen nach - Anzahl. Die zweite Spalte müsste bereits automatisch die Summe haben.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHI
1KundennameBestellnummerBestellwertKanal     
2Kunde1O3321250,00 €FilialeA     
3Kunde2O5467100,00 €Filiale B     
4Kunde3O934425,00 €Filiale A     
5Kunde1O822340,00 €Filiale A     
6Kunde3O914375,00 €Filiale B  ZeilenbeschriftungenAnzahl von BestellwertSumme von Bestellwert2
7Kunde1O845325,00 €Filiale A  Kunde13315
8      Kunde21100
9      Kunde32100
10      Gesamtergebnis6515
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • Excel2007Newbie
Antwortento top
#3
Hallo Peter,

vorab vielen Dank für Deine schnelle Antwort. Ja, damit käme ich schon zurecht, allerdings möchte ich darüber hinaus  den Vorgang gern verstehen und manuell , auch ohne Pivot, ausführen können.


Hast Du vielleicht hierz eine Anregung, die mich weiterbringen würde?

Viele Grüße




Peter

Hallo,

ich würde das mit einer Pivottabelle machen.

Eine Zelle der Datentabelle markieren - Einfügen - Pivottable und dem Assistenten folgen.

Ziehe das Feld Kundenname in die Zeilenbeschriftung und das Feld Bestellwert zweimal in das Wertefeld.

Markiere eine Zelle im Wertefeld - rechte Maus - Werte zusammenfassen nach - Anzahl. Die zweite Spalte müsste bereits automatisch die Summe haben.

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHI
1KundennameBestellnummerBestellwertKanal     
2Kunde1O3321250,00 €FilialeA     
3Kunde2O5467100,00 €Filiale B     
4Kunde3O934425,00 €Filiale A     
5Kunde1O822340,00 €Filiale A     
6Kunde3O914375,00 €Filiale B  ZeilenbeschriftungenAnzahl von BestellwertSumme von Bestellwert2
7Kunde1O845325,00 €Filiale A  Kunde13315
8      Kunde21100
9      Kunde32100
10      Gesamtergebnis6515
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Antwortento top
#4
Hallo,

formelmäßig geht das in Richtung Summewenn bzw. Zählenwenn, aber die PT ist m.E. hier die schnellste und effektivste Variante.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • Excel2007Newbie
Antwortento top
#5
Hi,

meinst du so?

Tabelle1

ABCD
1KundennameBestellnummerBestellwertKanal
2Kunde1O3321   250,00 € FilialeA
3Kunde2O5467   100,00 € Filiale B
4Kunde3O9344     25,00 € Filiale A
5Kunde1O8223     40,00 € Filiale A
6Kunde3O9143     75,00 € Filiale B
7Kunde1O8453     25,00 € Filiale A

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Tabellenblatt 2

Tabelle2

ABC
1Kunde13     315,00 €
2Kunde21     100,00 €
3Kunde32     100,00 €
Formeln der Tabelle
ZelleFormel
B1=ZÄHLENWENN(Tabelle1!$A$2:$A$7;A1)
C1=SUMMEWENN(Tabelle1!$A$2:$A$7;A1;Tabelle1!$C$2:$C$7)
B2=ZÄHLENWENN(Tabelle1!$A$2:$A$7;A2)
C2=SUMMEWENN(Tabelle1!$A$2:$A$7;A2;Tabelle1!$C$2:$C$7)
B3=ZÄHLENWENN(Tabelle1!$A$2:$A$7;A3)
C3=SUMMEWENN(Tabelle1!$A$2:$A$7;A3;Tabelle1!$C$2:$C$7)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Excel2007Newbie
Antwortento top
#6
Hallo,

noch ein kleiner Hinweis zum Beispiel von Günter:

Um die Kundennamen in Spalte A zu erhalten könntest du die Namen in das neue Tabellenblatt kopieren und die Duplikate dann über Menü Daten - Duplikate entfernen eliminieren.

Formelmäßig könnte man das auch lösen: http://www.excelformeln.de/formeln.html?welcher=194. Das ist aber ist eine Matrixformel und die sind entsprechend rechenintensiv, deswegen würde ich in diesem Fall eher Richtung Duplikate entfernen gehen.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • Excel2007Newbie
Antwortento top
#7
Smile 
Vielen Dank WillWissen,

ja in diese Richtung habe ich gedacht. Ich probiere dies aus und baue dies einmal in meine Tabelle ein.

Vielen Dank bereits schonmal für die schnellen und helfreichen Antworten.

Ein schönes Wochenende.

Viele Grüße Smile
Antwortento top
#8
Hallo, sowas ist das auch automatisch (was bei PivotTable und SpezialFilter nicht so einfach ist) mit den DatenBankfunktionen möglich..: (zudem kann man die Kriterien auch kombinieren...)

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEFGHIJ
1KundennameBestellnummerBestellwertKanal  KundennameBestellnummerBestellwertKanal
2Kunde1O3321250FilialeA    <>0 
3Kunde2O5467100Filiale B      
4Kunde3O934425Filiale A   AnzahlSumme 
5Kunde1O822340Filiale A   6515 
6Kunde3O914375Filiale B  Kunde13315 
7Kunde1O845325Filiale A  Kunde21100 
8      Kunde32100 

ZelleFormel
H5=DBANZAHL2(A1:D7;1;G1:J2)
I5=DBSUMME($A$1:$D$7;3;G1:J2)
H6{=MEHRFACHOPERATION(;G2)}
I6{=MEHRFACHOPERATION(;G2)}
H7{=MEHRFACHOPERATION(;G2)}
I7{=MEHRFACHOPERATION(;G2)}
H8{=MEHRFACHOPERATION(;G2)}
I8{=MEHRFACHOPERATION(;G2)}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste