Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Berechnung ohne ausgeblendete Zeilen?
#1
Hallo zusammen,

vielleicht und hoffentlich kann mir jemand bei meinem Problem helfen?!
Ich habe eine größere Datenmenge und zähle in dieser nach Einträgen pro Monat.

Mein Problem ist, wenn ich mittels Filter Einträge ausblende, werden diese trotzdem mitgezählt und dieses würde ich gerne verhindern.
Möglich wird das ganze wohl mit "Teilergebnis" allerdings bekomme ich die Formel irgendwie nicht auf die Reihe und wäre dankbar, wenn mir jemand helfen könnte.

Mit dieser Formel:
=SUMMENPRODUKT(((MONAT('2016 Tickets'!D2:D6794)=1)*(JAHR('2016 Tickets'!D2:D6794)=2016)))
zähle ich auf dem Blatt "2016 Tickets" die entsprechende Anzahl pro Monat und nun würde ich gerne wissen, ob mir jemand sagen kann, wie diese Formel formuliert werden müsste um nur angezeigte (ohne die ausgefilterten) Werte zu zählen?

Ich hoffe, es ist einigermaßen verständlich, was ich eigentlich meine. :-)

Vorab schon vielen Dank!
Antwortento top
#2
Hallo,

auch die Funktion "=aggregat()" erlaubt nur nicht-ausgeblendete Zeilen zu bearbeiten.

mfg
Antwortento top
#3
(16.01.2017, 19:32)Fennek schrieb: Hallo,

auch die Funktion "=aggregat()" erlaubt nur nicht-ausgeblendete Zeilen zu bearbeiten.

mfg

Hallo, ist aber hier sicher nicht anwendbar...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#4
Hallo,

klare Ansage: Diese Formel zählt nie und nimmer die Anzahl der Tickets, sondern lediglich, wieviel Einträge es im Januar 2016 gab (außer, jeder Eintrag ist 1Ticket)!
Wenn Du sowieso filterst, dann filtere doch nach Monat und Jahr, dann kannst Du mit einem einfachen Teilergebnis die Summe bilden:

Tabelle1

ABCDE
1DatumAnzahl182597
1202.02.20167
1302.02.201611
1416.02.201611
1520.02.20167
1625.02.201610
1728.02.20167
1829.02.20166
Formeln der Tabelle
ZelleFormel
C1=SUMME(B2:B21)
D1=TEILERGEBNIS(109;B2:B21)
E1=TEILERGEBNIS(103;A12:A21)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8





Tabelle1

ABCD
1DatumAnzahl182182
201.01.20167
302.01.201610
403.01.201611
512.01.201610
615.01.20166
722.01.201610
824.01.201612
925.01.201612
1029.01.20166
1129.01.20165
1202.02.20167
1302.02.201611
1416.02.201611
1520.02.20167
1625.02.201610
1728.02.20167
1829.02.20166
1903.03.201615
2009.03.20165
2115.03.201614
Formeln der Tabelle
ZelleFormel
C1=SUMME(B2:B21)
D1=TEILERGEBNIS(109;B2:B21)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • CAS
Antwortento top
#5
Vielen Dank für Deine Antwort und Deine Mühe!
Ist wahrscheinlich der beste Weg und Du liegst richtig, jeder Eintrag ist in meinem Fall 1 Ticket.
Antwortento top
#6
Hallo,

das könnte man aber auch mit einer Hilfsspalte und Pivot erledigen:

Tabelle1

EF
2ZeilenbeschriftungenAnzahl von Zahl
3160110
416027
516033
6Gesamtergebnis20

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste