Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Auszählung nach Tagen und zusammenhängenden Stundenwerten
#1
Rainbow 
Hallo Zusammen,

anbei unsere zu bearbeitende Datei:

Excel-Tabelle

Wir zermartern uns an folgendem Problem den Kopf:

Wir würden gerne die Anzahl der Tage wissen, an denen jeweils 6 Mal hintereinander oder öfters eine
1 auftaucht. D.h. also, wenn z.B. am 23.01.03 von 10:00 bis 22:00 (also mehr als 6 h Stunden hintereinander) eine 1 erscheint, soll dieser Tag gezählt werden. Sollten an einem Tag mehrere 6h-Blöcke vorkommen, soll der Tag nur einmal gezählt werden.

Über Eure Hilfe wären wir sehr dankbar!

Ich hoffe die schlauen Köpfe aus dem alten Clever-Excel-Forum sind jetzt alle hier90

Hucho
to top
#2
Hallo Zusammen,

kann es sein, dass wir hier vor einer Problemstellung stehen, die für Excel und seine Anwender nicht lösbar ist?
to top
#3
Hallo Hucho,

aus meiner Sicht kann es mit mehreren Schritten funktionierren:

1. alle mit 1 filtern

2.alle gefilterten auf ein neues Blatt kopieren

3. hierüber eine Pivot-Tabelle erstellen

4. das Datum in der Pivot-Tabelle nach Tag gruppieren

5. dann wieder kopieren in normales "Excel"

6. mit dem Autofilter alle größer 6 rausholen

---> siehe Datei in der Anlage

LG Margit


Angehängte Dateien
.xlsx   Mappe1_panjakira.xlsx (Größe: 61,93 KB / Downloads: 3)
to top
#4
Hallo,

mit einer Hilfsspalte in D:

Code:
=WENN((SUMME(B3:B8)=6)*(SUMMEWENNS($D$2:D2;$A$2:A2;">="&KÜRZEN(A3;);$A$2:A2;"<"&KÜRZEN(A3;)+1)=0);1;"")

dann irgendwo die Summe über diese Spalte bilden.

Arbeitsblatt mit dem Namen 'aufgefüll_Verweis kopie Werte'
 ABCDEF
1DatumAnzahl von 1 Zahl 10
22.1.03 8:000 0  
32.1.03 9:000    
42.1.03 10:000    
52.1.03 11:001    
62.1.03 12:001    
72.1.03 13:001    
82.1.03 14:001    
92.1.03 15:000    
102.1.03 16:000    
112.1.03 17:001    
122.1.03 18:000    
132.1.03 19:001    
142.1.03 20:001    
152.1.03 21:001    
162.1.03 22:001    
172.1.03 23:000    
183.1.03 0:000    
193.1.03 1:000    
203.1.03 2:000    
213.1.03 3:000    
223.1.03 4:000    
233.1.03 5:000    
243.1.03 6:001    
253.1.03 7:000    
263.1.03 8:000    
273.1.03 9:001    
283.1.03 10:001    
293.1.03 11:000    
303.1.03 12:001 1  
313.1.03 13:001    
323.1.03 14:001    

ZelleFormel
D3=WENN((SUMME(B3:B8)=6)*(SUMMEWENNS($D$2:D2;$A$2:A2;">="&KÜRZEN(A3Wink;$A$2:A2;"<"&KÜRZEN(A3Wink+1)=0);1;"")
F1=SUMME(D:D)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • Hucho
to top
#5
Hallo BoskoBiati,

vielen Dank für deinen Lösungsvorschlag - das funktioniert super.

Wärst Du so nett, deine Formel noch kurz zu erläutern:

1. Das logische * ist mir z.B. bekannt im Zusammenhang mit der Formel "summenprodukt"; mir war nicht klar, dass das auch in einer wenn-Funktion arbeitet
2. Der zweite Teil der Formel mit "summewenns..." macht mir Schwierigkeiten zu verstehen; Summwenns natürlich nicht, aber Teil mit dem "Kürzen".

Vielen Dank!

Grüße,

Hucho
to top
#6
Hallo,

das * zwischen zwei Prüfungen ist nichts anderes als die UND-Verknüpfung.

Kürzen macht aus Deiner Datum/Zeit-angabe in A eine reine Datumsangabe, da sonst die Vergleiche nicht klappen.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top
#7
Echt genial! Danke nochmals!
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste