Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auslesen mittels Index und Vergleich innerhalb einer Wenn-Fkt
#1
Hallo ich hoffe ich konnte die Ausschnitte einigermaßen passend auswählen,

trotzdem im Anhang die Original Version.

In den Felder I und J 5 befindet sich jeweils eine Dropdownliste Tabellenausschnitt 1.
Die Auswahmöglichkeiten setzen sich aus den Reihen M Tabellenausschnitt 2 und R Tabellenauschnitt 3 zusammen, dies habe ich eine hier nicht abgebildete Liste auf der Alle Elemente drauf sind gelöst.

Im Tabellenauschnitt 1 steht die Zeile 5 für die Startzeit, Zeile 6 für die Endzeit und Zeile 7 für die Pause hieraus wird ein Rest gebildet =Rest(J7-J6-J8;0); dieser soll verwendet werden Wenn im Dropdown Menü ~~ ausgewählt wurde.

Wenn im Feld J5 ein Element der Liste Sonder; Abschnitt 2 Reihe M; ausgewählt wird soll Excel aus der Tabelle im Abschnitt die Passende Stundenzahl auslesen hierbei sollen verschiedene Personen berücksichtigt werden z.B. Auswahl BS1/2; Geitmann --> 1:00. Außerdem wird der Wert aus der oben erwähnten Restfunktion hinzu addiert 1:00 + 7:55 = 8;55. Bis zu diesem Punkt funktioniert alles super.

Jetzt soll aber, wenn ein Element aus dem Liste Sonderhalb; Abschnitt 3 Reihe R; ausgewählt nur der Wert genommen werden, z.B. Bub; Geitmann --> 1:00.

Leider geht das nicht und es wird nur #NV angezeigt ; hierzu Abschnitt 6.

Zu Test zwecken habe ich die Formel einfach mal umgedreht und Sie führt aus zu um Ergebnissen der "Sonst" -Abschnitt der der 2. Wenn Fkt Führt zu #NV hier zu Tabellenabschnitt 1 Reihe I und Tabellenabschnitt 6 Reihe I.

Im Tabellenabschnitt 5 ist die von mir verwendete Wenn-Fkt. ich hoffe man versteht meine Problembeschreibung, wenn nicht trotzdem bitte Antworten damit ich es vllt. noch konkretisieren kann.

Und jmd hat eine Idee wie das Problem zu lösen ist.

Grüße

Björn


Januar
IJ
5BubBS1/2
66:206:20
714:3014:30
80:150:15
98:558:55

Januar
MNOP
13SonderNowackGeitmann
14U1/20,54:001:00
15U18:002:00
16K1/20,54:001:00
17K18:002:00
18BS1/20,54:001:00
19BS18:002:00
20~~


Januar
RSTU
13Sonder1/2NowackGeitmann
14Bub0,54:001:00
15Lun0,58:002:00
16Gur0,54:001:00

verwendete Formeln
Zelle Formel Bereich N/A
I9=WENN(I5="~~";REST(I7-I6-I8;1);WENN(VERGLEICH(I5;Sonderhalb;0);(INDEX($T$14:$U$16;VERGLEICH(I5;Sonderhalb;0);VERGLEICH($B$4;$T$13:$U$13;0))+REST(J7-J6-J8;1));INDEX($O$14:$P$19;VERGLEICH(I5;Sonder;0);VERGLEICH($B$4;$O$13:$P$13;0))))
J9=WENN(J5="~~";REST(J7-J6-J8;1);WENN(VERGLEICH(J5;Sonder;0);(INDEX($O$14:$P$19;VERGLEICH(J5;Sonder;0);VERGLEICH($B$4;$O$13:$P$13;0))+REST(J7-J6-J8;1));INDEX($T$14:$U$16;VERGLEICH(J5;Sonderhalb;0);VERGLEICH($B$4;$T$13:$U$13;0))))
O14: P19=INDEX($K$15:$K$16;VERGLEICH(O$13;$H$15:$H$16;0))*$N14
T14:U16=INDEX($K$15:$K$16;VERGLEICH(O$13;$H$15:$H$16;0))*$N14

definierte Namen
Name Bezieht sich auf Tabelle Z1S1-Formel
Sonder=Januar!$M$14:$M$20=Januar!R14C13:R20C13
Sonderhalb=Januar!$R$14:$R$16=Januar!R14C18:R16C18
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.05 einschl. 64 Bit




Januar
IJ
5BS1/2Bub
66:206:20
714:3014:30
80:150:15
9#NV#NV

verwendete Formeln
Zelle Formel Bereich N/A
I9=WENN(I5="~~";REST(I7-I6-I8;1);WENN(VERGLEICH(I5;Sonderhalb;0);(INDEX($T$14:$U$16;VERGLEICH(I5;Sonderhalb;0);VERGLEICH($B$4;$T$13:$U$13;0))+REST(J7-J6-J8;1));INDEX($O$14:$P$19;VERGLEICH(I5;Sonder;0);VERGLEICH($B$4;$O$13:$P$13;0))))
J9=WENN(J5="~~";REST(J7-J6-J8;1);WENN(VERGLEICH(J5;Sonder;0);(INDEX($O$14:$P$19;VERGLEICH(J5;Sonder;0);VERGLEICH($B$4;$O$13:$P$13;0))+REST(J7-J6-J8;1));INDEX($T$14:$U$16;VERGLEICH(J5;Sonderhalb;0);VERGLEICH($B$4;$T$13:$U$13;0))))

definierte Namen
Name Bezieht sich auf Tabelle Z1S1-Formel
Sonder=Januar!$M$14:$M$20=Januar!R14C13:R20C13
Sonderhalb=Januar!$R$14:$R$16=Januar!R14C18:R16C18
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.05 einschl. 64 Bit


.xlsx   Übersichttest2b.xlsx (Größe: 15,34 KB / Downloads: 1)
Antwortento top
#2
Hallo,


Code:
=WENN(I5="~~";REST(I7-I6-I8;1);WENN(ISTZAHL(VERGLEICH(I5;Sonderhalb;0));(INDEX($T$14:$U$16;VERGLEICH(I5;Sonderhalb;0);VERGLEICH($B$4;$T$13:$U$13;0))+REST(J7-J6-J8;1));INDEX($O$14:$P$19;VERGLEICH(I5;Sonder;0);VERGLEICH($B$4;$O$13:$P$13;0))))
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • kruesae
Antwortento top
#3
Vielen Dank Funktioniert super. Ich würde mich über eine kurze Erläuterung freuen die mir erklärt warum mein Ansatz nicht funktionierte und dieser schon.

Grüße

Björn
Antwortento top
#4
Hallo, 

der Vergleich findet etwas oder er gibt #NV  zurück. Wenn das Ergebnis #NV ist, dann ist das nicht mehr weiter berechenbar .
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste