Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Ausgabe einer Rechnung anders darstellen
#1
Schönen Guten Abend

Eigentlich ist meine frage recht einfach.
Da ich aber nicht weiß wonach ich suchen soll, bin ich leider selber zu keiner Lösung gekommen.

Ich Würde gerne das Ergebnis einer Multiplikation anders darstellen.

2000/120=16,66667 wäre jetzt C1=A1/120

Würde das Ergebnis aber gerne in diesem Erscheinungsbild haben : 16*120+1*80

Ist das so möglich und könnt ihr mir helfen?

LG Graf Schlumpf
Antwortento top
#2
Hallo,

mir ist im Moment nicht ganz klar auf was du genau hinaus willst.

Du sprichst du vom Ergebnis einer Multiplikation, aber dein Beispiel
Zitat:C1=A1/120
passt nicht dazu und
Zitat:16*120+1*80
kriege ich da auch nicht in die Reihe.

Könntest du dein Vorhaben etwas genauer erklären - soll evtl. die Formel
Zitat:16*120+1*80
in der Zelle stehen ohne dass das entsprechende Ergebnis berechnet wird?
Gruß
Peter
Antwortento top
#3
Sorry, war ein Fehler von mir, meinte natürlich Division also teilen.29

Es geht sich in dem Ergebnis um Stücke.
Also ausgehend von einer Länge von 2000 Metern und einer Stücklänge von 120 Metern,
hätte ich dann 16 Stücke a 120 Metern und ein Stück mit 80 Metern.

Wenn ich Excel jetzt einfach nur geteilt Rechnen lasse gibt er mir halt nur diese 16,66667 aus.
Das ist ja auch richtig, sieht aber in meiner Tabelle nicht so schön aus.
Optimal wäre natürlich eine Ausgabe wie 16 stk. + 80 m

Hoffe ich habe es jetzt verständlich rübergebracht 26

Vielen Dank Für die Bemühungen
Antwortento top
#4
Hallo,

ich habe das jetzt nicht mit anderen Werten getestet, das überlasse ich dir:

=GANZZAHL(A1/B1) &" Stck " &TEXT(REST(A1/B1;1)*B1;"0")&" m"

Ach ja, vergessen:

In A1 steht 2000 und in B1 die 120.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • Graf Schlumpf
Antwortento top
#5
Hi,

hier eine Lösung mit 2 Hilfsspalten

Tabelle4

ABCDE
1200012016,66666678016*120 +1*80
2100010010010*100 +1*0
Formeln der Tabelle
ZelleFormel
C1=A1/B1
D1=A1-(GANZZAHL(C1)*B1)
E1=GANZZAHL(C1)&"*"&B1&" +1*"&D1
C2=A2/B2
D2=A2-(GANZZAHL(C2)*B2)
E2=GANZZAHL(C2)&"*"&B2&" +1*"&D2

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
Antwortento top
#6
Vielen Dank, Peter und WillWissen!

Habe aber Peters Formel genommen, sieht schöner aus Smile

Aber deine Formel, WillWissen hat ja auch genau das gemacht was ich im Startpost gefragt habe.

Habe Peters Formel noch ein wenig abgeändert. Füge Sie mal ein, funktioniert so bei mir.

=WENN(O26="";"";GANZZAHL(O26/120) &" Stck. + " &TEXT(REST(O26/120;1)*120;"0")&" m")

Wenn der ausgegebene Rest 0 ist, kann ich ihn mit einer Wenn Funktion ausblenden bzw. nicht anzeigen lassen???
Habe es mal so versucht, hat aber nicht geklappt Sad
=WENN(O26="";"";GANZZAHL(O26/120) &" Stck. + " &TEXT Wenn((REST(O26/120;1)*120;"0")&" m")=0;"";(REST(O26/120;1)*120;"0")&" m"))
Antwortento top
#7
Hi,
auch wenn dir Peters Formel sympatischer ist, meine Lösung zum Weglassen der "0":

Code:
=GANZZAHL(C1)&"*"&B1&WENN(D1<>0;" +1*"&D1;"")

Und so sieht die Formel bei Peters Lösung aus:

Code:
=GANZZAHL(A2/B2)&" Stck "&WENN(TEXT(REST(A2/B2;1)=0;"");"";TEXT(REST(A2/B2;1)*B2;"0")&" m")

Edit: Formelergänzung Peters Formel
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Graf Schlumpf
Antwortento top
#8
(22.11.2014, 21:28)Graf Schlumpf schrieb: Habe aber Peters Formel genommen, sieht schöner aus Smile

Aber deine Formel, WillWissen hat ja auch genau das gemacht was ich im Startpost gefragt habe.

für mich als Formel-Anfänger ist Günters Formel einfacher zu verstehen und nachzuvollziehen.
Antwortento top
#9
Verstanden habe ich Peters Formel auch noch nicht so wirklich, konnte sie aber für mich anpassen.

Verwende sie jetzt so

Code:
=WENN(O2="";"";GANZZAHL(O2/120)&" Stck. "&WENN(TEXT(REST(O2/120;1)=0;"");"";TEXT(REST(O2/120;1)*120;"0")&" m"))

Muß mir das noch einmal in Ruhe anschauen.
Antwortento top
#10
Hallo,

bei der Wenn-Funktion kannst du auf das Text verzichten:

Code:
=WENN(O2="";"";GANZZAHL(O2/120)&" Stck. "&WENN(REST(O2/120;1)=0;"";TEXT(REST(O2/120;1)*120;"0")&" m"))

und wenn du lieber auf die Funktion Rest() verzichten willst dann z.B. so:

Code:
=WENN(O2="";"";GANZZAHL(O2/120)&" Stck. "&WENN((O2/120-GANZZAHL(O2/120))=0;"";TEXT((O2/120-GANZZAHL(O2/120))*120;"0")&" m"))
Gruß
Peter
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste