Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Aus Zeilen m. Stundenwerten relevante filtern und summieren
#1
Ich habe eine Tabelle mit vielen Zeilen, die je für eine bestimmte, fortlaufende Stunde stehen und die in dieser Stunde gefallene Regenmenge enthalten.
Nun möchte ich rausfiltern, an welchen Tagen und Uhrzeiten z.B. in 72 h eine Regenmenge über 55 mm gefallen ist und welche Regenmenge das genau war.

Bisher habe ich es nur geschafft, alle Zellen rauszufiltern, die Teil eines solchen Regens sind - nur möchte ich ja pro Regen nur EINE Ergebniszeile mit dem gesamten Zeitraum und der Gesamtregenmenge. Huh

Ich hoffe, man versteht, was ich meine... Ich habe die Tabelle mal in den Anhang gepackt.

Vielen Dank schon mal für alle Hilfeversuche...!


Angehängte Dateien
.xlsx   Niederschlagstabelle.xlsx (Größe: 78,42 KB / Downloads: 14)
to top
#2
Hallo,

mit drei vier Klicks nur, ohne Formeln und ohne VBA, habe ich dieses Ergebnis erhalten:
Arbeitsblatt mit dem Namen '2009'
 EF
1ZeilenbeschriftungenSumme von Stundensumme Regen
201.07.2009 - 03.07.200914,8
304.07.2009 - 06.07.200912,3
407.07.2009 - 09.07.20094,3
510.07.2009 - 12.07.20091
613.07.2009 - 15.07.200951,9
716.07.2009 - 18.07.200933,7
819.07.2009 - 21.07.20090,2
922.07.2009 - 24.07.20096
1025.07.2009 - 27.07.20091,9
1128.07.2009 - 30.07.20091,4
1231.07.2009 - 02.08.20095,3
1303.08.2009 - 05.08.20090
1406.08.2009 - 08.08.200935,8
1509.08.2009 - 11.08.200915
1612.08.2009 - 14.08.20098,2
1715.08.2009 - 17.08.20094,2
1818.08.2009 - 20.08.20090
1921.08.2009 - 23.08.20091
2024.08.2009 - 26.08.20094,5
2127.08.2009 - 29.08.20090
2230.08.2009 - 01.09.20090,3
2302.09.2009 - 04.09.200910,3
2405.09.2009 - 07.09.20090,1
2508.09.2009 - 10.09.20090
2611.09.2009 - 13.09.20090,8
2714.09.2009 - 16.09.20097,2
2817.09.2009 - 19.09.20090,3
2920.09.2009 - 22.09.20090,1
3023.09.2009 - 25.09.20090
3126.09.2009 - 28.09.20090
3229.09.2009 - 01.10.20090
3302.10.2009 - 04.10.20090
3405.10.2009 - 07.10.200915,5
3508.10.2009 - 10.10.200926,9
3611.10.2009 - 13.10.200914,5
3714.10.2009 - 16.10.20092,3
3817.10.2009 - 19.10.200911
3920.10.2009 - 22.10.20090,4
4023.10.2009 - 25.10.20095,2
4126.10.2009 - 28.10.20090
4229.10.2009 - 31.10.20090,1
4301.11.2009 - 03.11.200912,1
4404.11.2009 - 06.11.20095,3
4507.11.2009 - 09.11.200919,8
4610.11.2009 - 12.11.20090,8
4713.11.2009 - 15.11.20091,8
4816.11.2009 - 18.11.200911,3
4919.11.2009 - 21.11.20090
5022.11.2009 - 24.11.20093,8
5125.11.2009 - 27.11.20090,8
5228.11.2009 - 30.11.200917,8
5301.12.2009 - 03.12.20098,3
5404.12.2009 - 06.12.20093,5
5507.12.2009 - 09.12.20098,6
5610.12.2009 - 12.12.200917,2
5713.12.2009 - 15.12.20090,1
5816.12.2009 - 18.12.20090
5919.12.2009 - 21.12.20093,4
6022.12.2009 - 24.12.200912,1
6125.12.2009 - 27.12.20091
6228.12.2009 - 30.12.20099,4
6331.12.2009 - 01.01.20101,5
64Gesamtergebnis435,1
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Ich hatte Dir ja im letzten Beitrag schon die Pivottabelle vorgeschlagen.
Das obige Ergebnis ist eine Pivottabelle, und die kann noch viel mehr.
Gruß Atilla
to top
#3
Hallo Atilla,

das sieht auf jeden Fall schon viel übersichtlicher aus Smile Mein Problem ist aber, dass ich die Werte nicht in erster Linie nach Tagen unterteilen möchte, sondern nach den Niederschlagssummen. Sprich, wenn z.B. die beiden Summen der Zeiträume 6.-8.8. und 9.-11.8. unter dem Schwellenwert (z.B. 40) liegen, allerdings der Zeitraum 7.-10.8. darüber, weil eben am 7. und am 9. besonders viel Regen gefallen ist.

Das wird jetzt in der Tabelle wahrscheinlich nicht der Fall sein, aber solche Fälle würde ich gerne irgendwie detektieren...

Vielen Dank für eure Geduld Angel
to top
#4
Hallo Chris,

die zweite Bedingung habe ich in Deiner Frage ganz überlesen.
Sorry, auf die Schnelle habe ich dafür keine Antwort. Ich kenne mich eher mit
primitiven Formelkonstrukten aus. Da müssen Formelspezialisten ran.

Melde Dich wieder, wenn längere Zeit keine Lösung gepostet wurde.
Gruß Atilla
to top
#5
Hallo Chris,

im Prinzip so. Da müsste nur noch der Stundenversatz rein. Ich nehme an, dass das Zieldatum dann auch um 3 Stunden in den nächsten Tag verschoben werden soll?

Arbeitsblatt mit dem Namen '2009'
 KLMNO
3Beispiel für eine Ziel-Tabelle:    
4Datum vonDatum bisStart-StundeRegensumme über 72 h 
501.07.200903.07.2009314,8 
602.07.200904.07.2009314,8 
703.07.200905.07.2009315,2 
804.07.200906.07.2009312,3 
905.07.200907.07.2009312,8 
1006.07.200908.07.2009315 
1107.07.200909.07.200934,3 
1208.07.200910.07.200934,2 
13     

ZelleFormel
N5=SUMMEWENNS($C$2:$C$1000;$A$2:$A$1000;">="&K5;$A$2:$A$1000;"<="&L5)
N6=SUMMEWENNS($C$2:$C$1000;$A$2:$A$1000;">="&K6;$A$2:$A$1000;"<="&L6)
N7=SUMMEWENNS($C$2:$C$1000;$A$2:$A$1000;">="&K7;$A$2:$A$1000;"<="&L7)
N8=SUMMEWENNS($C$2:$C$1000;$A$2:$A$1000;">="&K8;$A$2:$A$1000;"<="&L8)
N9=SUMMEWENNS($C$2:$C$1000;$A$2:$A$1000;">="&K9;$A$2:$A$1000;"<="&L9)
N10=SUMMEWENNS($C$2:$C$1000;$A$2:$A$1000;">="&K10;$A$2:$A$1000;"<="&L10)
N11=SUMMEWENNS($C$2:$C$1000;$A$2:$A$1000;">="&K11;$A$2:$A$1000;"<="&L11)
N12=SUMMEWENNS($C$2:$C$1000;$A$2:$A$1000;">="&K12;$A$2:$A$1000;"<="&L12)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
to top
#6
Hallo André,

das sieht gut aus, auf diese Weise würde ja jede "3-Tage-Kombination" abgedeckt. Wenn auch nicht sämtliche Start-Stunden, aber ich denke darauf kann ich verzichten... 30

Nur eine Frage: Wie bekomme ich denn die Ziel-Tabelle in diese Form? Also die Spalten "Datum von", "Datum bis" und "Start-Stunde"? Huh Geht das irgendwie mit der Pivot-Tabelle!?

Tausend Dank für den Einsatz!!
[-] Folgende(r) 1 Benutzer sagt Danke an chris3o12 für diesen Beitrag:
  • schauan
to top
#7
Hallo,

wenn ich das richtig interpretiere, dann mit zwei Hilfsspalten (D u. E) so:

Arbeitsblatt mit dem Namen '2009'
 ABCDEFGHIJKLMN
1TagStundeStundensumme Regen           
201.07.20090000         
301.07.20091000     Beispiel für eine Ziel-Tabelle:   
401.07.20092000     DatumStart-StundeRegensumme über 72 h 
501.07.20093000     03.07.09 -06.07.091526,3 
601.07.20094000     05.07.09 -08.07.091713 
701.07.20095000     06.07.09 -09.07.09215 
801.07.20096000     06.07.09 -09.07.09214,4 
901.07.20097000     08.07.09 -11.07.09184 
1001.07.20098000     09.07.09 -12.07.09221,7 
1101.07.20099000         
1201.07.200910000         
1301.07.200911000         

ZelleFormel
D2=((C1=0)*100+(C2>0)*10+(C3>0)=111)*(SUMME(INDEX(C:C;ZEILE()):INDEX(C:C;ZEILE()+71)))
E2=(D2>32)*(MAX($E$1:E1)+(D2>32))
K5=TEXT(INDEX(A:A;VERGLEICH(ZEILE($A1);$E:$E;0));"TT.MM.JJ")&" -"&TEXT(INDEX(A:A;VERGLEICH(ZEILE($A1);$E:$E;0)+71);"TT.MM.JJ")
L5=INDEX(B:B;VERGLEICH(ZEILE($A1);$E:$E;0))
M5=INDEX(D:D;VERGLEICH(ZEILE($A1);$E:$E;0))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg


Als Grenzwert habe ich in E mal 32mm eingesetzt, damit ich Ergebnisse habe. Mit Variablen Grenzwerten:

Arbeitsblatt mit dem Namen '2009'
 ABCDEFGHIJKLMN
1TagStundeStundensumme Regen           
201.07.20090000         
301.07.20091000     Beispiel für eine Ziel-Tabelle: unterer Grenzwert: 50mm 
401.07.20092000     DatumStart-StundeRegensumme über 72 h 
501.07.20093000     13.07.09 -16.07.09252,6 
601.07.20094000     14.07.09 -17.07.09551,3 
701.07.20095000     15.07.09 -17.07.09071,9 
801.07.20096000     08.08.09 -11.08.091650,8 
901.07.20097000         

ZelleFormatWert
M3"unterer Grenzwert: "#.##0"mm"50

ZelleFormel
D2=((C1=0)*100+(C2>0)*10+(C3>0)=111)*(SUMME(INDEX(C:C;ZEILE()):INDEX(C:C;ZEILE()+71)))
E2=(D2>=$M$3)*(MAX($E$1:E1)+(D2>=$M$3))
K5=WENNFEHLER(TEXT(INDEX(A:A;VERGLEICH(ZEILE($A1);$E:$E;0));"TT.MM.JJ")&" -"&TEXT(INDEX(A:A;VERGLEICH(ZEILE($A1);$E:$E;0)+71);"TT.MM.JJ");"")
L5=WENNFEHLER(INDEX(B:B;VERGLEICH(ZEILE($A1);$E:$E;0));"")
M5=WENNFEHLER(INDEX(D:D;VERGLEICH(ZEILE($A1);$E:$E;0));"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste