Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Aus Gesamtliste neue Liste erstellen
#1
Hallo zusammen,

ich möchte eine Liste erstellen die alle Stammdaten enthält und von dort aus nur noch mit Verlinkungen arbeiten, damit man nur eine Datensatz ändern muss.

Anbei die Beispieltabelle. Diese enthält Personendaten. Ich möchte aus dieser Liste nun eine Art Unterbringungsliste erstellen.
Sprich in einer anderen Exceltabelle sollen nach Objekten sortiert die Personendaten angezeigt werden.

Wenn ich bei den Stammdaten die Anschrift ändere, möchte ich dass das in der Unterbringungsliste direkt verarbeitet wird.

Welche Möglichkeiten habe ich da? Oder muss ich mit VBA was ganz eigenes erstellen?

Vorab schonmal vielen Dank!


Angehängte Dateien
.xlsx   test.xlsx (Größe: 9,87 KB / Downloads: 4)
Antwortento top
#2
Hola,

da du kein Wunschergebnis zeigst, habe ich geraten - hier das Beispiel für Musterstr. 1:


Code:
=WENNFEHLER(INDEX(Tabelle1!A$2:A$6;AGGREGAT(15;6;ZEILE($2:$6)-1/(Tabelle1!$H$2:$H$6="musterstr. 1");ZEILE(A1)));"")

Die Formel nach rechts und nach unten kopieren.

Gruß,
steve1da
Antwortento top
#3
Das ist perfekt - ich werde damit jetzt mal rumexperimentieren, aber das sieht richtig gut aus!

Beim nächsten mal erstelle ich auch ein Wunschergebnis!

Edit: Kannst du die Formel eventuell erklären?
Ich habe in der Beispieltabelle nur eine vereinfachte Version erstellt. Ich brauche eigentlich nicht alle Daten, sprich ich brauche eventuell nur Name, Vorname und Alter.

Aber die Formel kann ich mir nicht selbst erklären.
Antwortento top
#4
Hola,

die Formel durchsucht den Bereich mit den Straßen nach dem Suchkriterium und gibt nacheinander die Treffer zurück.
Was genau zurückgegeben wird, wird im Index-Teil geregelt. Hier also der Name. Ich habe die Formel so geschrieben, dass beim nach rechts ziehen auch der Index-Bereich auf die nächste Spalte verändert wird.

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste