Das Clever-Excel-Forum.de - Treffen
... 14.-16. September 2018 im Allgäu ...

Aufrunden
#1
Hallo,

ich möchte gerne folgendes mit Excel erstellen:
Täglich steigt der Betrag x €. Sobald es mehr als 60 € sind, dann addiere zu Spalte A eins dazu.

Ich habe das Problem mit VRUNDEN versucht zu lösen.
Aber leider gibt es auch Vielfaches kleiner 1 aus. Also auch 30, weil es 1/2 Vielfaches von 60 ist.

Weiß jemand eine Möglichkeit mit Excel nur die Vielfachen größer 1 auszugeben?


Viele Grüße
tundrablume
to top
#2
Hallo Tundrablume,

ich verstehe nicht, was du genau erreichen willst.
Deine Angaben sind für mich recht unverständlich.
Stelle doch mal eine Beispieldatei ein, in der man erkennen kann, was du erreichen willst.
Wie das geht, kannst du hier nachlesen.
Gruß Conny Smile
_______________________________________________________________

Die Summe der Intelligenz auf unserem Planeten ist konstant, aber die Bevölkerung wächst!
to top
#3
Hi,

mal ein Versuch, ob ich dich richtig verstanden habe:

Tabelle1

AB
1290
2310
3590
4611
51191
61212
71792
81813
Formeln der Tabelle
ZelleFormel
B1=GANZZAHL(A1/60)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#4
Hallo Günther,

genauso habe ich es gemeint. Danke Blush

Gibt es in Excel auch eine Funktion, um folgendes darzustellen:
Mit einem Paket steigt das Geld jeden Tag um eine bestimmte Variable.
Je mehr Pakete man hat, desto schneller steigt das Geld.
Sobald 50 € erreicht werden, kann man sich ein neues Paket kaufen.

Also gibt es eine Funktion, die dieses "sobald" ausgeben kann?


Viele Grüße
tundrablume
to top
#5
Moin,

jetzt antwortet wirklich der Günther, Blush 
ich könnte mir eine bedingte Formatierung vorstellen ...


Angehängte Dateien
.xlsx   Schwellenwert.xlsx (Größe: 13,83 KB / Downloads: 5)
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
to top
#6
Upsa, sorry Günther Blush 

Aber schade, dass Excel keine entsprechende Funktion hat.


Vielen Dank für die Tipps.


Grüße,
tundrablume
to top
#7
Na ja, das mit dem Namen ist aus meiner Sicht nicht ganz so tragisch ... Jeder von den beiden hier aktiven Günt(h)ers ist irgendwie stolz auf seine Schreibweise, es ist nun einmal ein Teil der Persönlichkeit. Aber wirklich übel nehmen wird dir weder der Günter noch ich, wenn einmal der Name nicht ganz korrekt geschrieben wird ...

Aber Gegenfrage zu8 deinem Einwand: Wie hättest du es denn gerne? Per bedingter Formatierung habe ich ja auch nur Excel-Funktionen verwendet. Mit VBA ist auch so einiges machbar!
Beste Grüße
  Günther

Excel-ist-sexy.de
  …schau doch mal rein!
Der Sicherheit meiner Daten wegen lade ich keine *.xlsm bzw. *.xlsb- Files mehr herunter! -> So geht's ohne!
to top
#8
Hi,

wäre das eine Lösungsmöglichkeit für dich?

Tabelle1

AC
1
220
340
460kaufen
580
6100kaufen
7120
8140
9160kaufen
Formeln der Tabelle
ZelleFormel
C2=WENN(ABRUNDEN(A2/50;0)*50=0;"";WENN(ABRUNDEN(A2/50;0)*50<>ABRUNDEN(A1/50;0)*50;"kaufen";""))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8


Beachte hierbei, dass die erste Zeile frei bleiben muss oder nur Überschriften enthält.

Und was mein Namensvetter (mit h 32) bzgl. unserer Schreibweisen gesagt hat, trifft voll und ganz zu. 19
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top
#9
Hallo Günter,


kleine Testfrage, wann kann dieser Ausdruck :

ABRUNDEN(A2/50;0)*50=0

den 0 als Ergebnis erhalten?



Und dann von mir auch eine Variante:


Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1WertStatus
220 
340 
460kaufen
580 
6100kaufen
7120 
8140 
9160kaufen

ZelleFormel
B2=WENN(KÜRZEN(A2/50;0)=(ZÄHLENWENN($B$1:B1;"kaufen")+1);"kaufen";"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla
to top
#10
Hi Atilla,

Zitat:kleine Testfrage, wann kann dieser Ausdruck :

ABRUNDEN(A2/50;0)*50=0

den 0 erhalten?

Wenn der Betrag noch unter 50€ liegt.

Tabelle1

AC
2200
3400
46050
Formeln der Tabelle
ZelleFormel
C2=ABRUNDEN(A2/50;0)*50

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) http://www.sprueche-zum-nachdenken.eu
to top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste