Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Array mit Formel
#1
Liebe Forumschaffende

Die Beispieltabelle im Anhang ist Teil eines Arbeitsplanes. Im Sheet Januar

- gehört jede Zeile einer Person
- wird in Spalte A mittels aufwändiger Zählenwenn Formel zusammen gerechnet, welche Zelle rechts davon wieviel Zeit benötigt.
- Dazu wird der Inhalt der Zellen E:AJ gezählt und auf das Sheet Variablen verwiesen um dort die angegebenen Zeiten mittels Spalte G zu summieren


Die Frage:
Die kleine Tabelle "Variablen" sollte um Bezeichungen und deren Pensen erweitert werden können (siehe "...") ohne, dass die Formel in Sheet Januar (+folgende) angepasst werden muss. Die Formel ist leider nur solange gut, bis die Tabelle in "Variablen" angepasst werden muss. Dies möchte ich verhindern. Und dies ohne VBA.

Ich kann mir keine Formel vorstellen, welche ich mit den mir bekannten Funktionen von Matrizen und Arrays, einfügen kann. Vielleicht liegt die Lösung ja ganz wo anders. Könnte mir jemand dabei helfen? Ich wäre sehr dankbar.

Lieber Gruss

mykophil


Angehängte Dateien
.xlsx   xample.xlsx (Größe: 17,03 KB / Downloads: 8)
Antwortento top
#2
Hallo,

Zitat:Die Beispieltabelle im Anhang ist Teil

Ich sehe keine Tabelle im Anhang.

Hier findest du eine Anleitung zum Hochladen von Dateien:

http://www.clever-excel-forum.de/Thread-...ng-stellen
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • mykophil
Antwortento top
#3
Hallo,

ich weiß jetzt nicht, ob ich etwas falsch mache, aber ich erhalte teilweise andere Ergebnisse:

Arbeitsblatt mit dem Namen 'Januar'
 AB
358:4884:00
4110:42127:30
558:480:00
68:240:00
70:000:00
8121:48117:36
90:000:00
100:000:00
11134:24134:24
1216:4816:48
13163:06163:06
14100:48100:48
15156:42181:54
160:000:00
1779:4821:00
180:000:00
190:000:00
200:000:00
21136:54136:54
220:000:00
23126:00126:00
24146:48172:00
250:000:00
26159:36159:36
270:000:00
280:000:00
290:000:00
300:000:00
310:000:00
32176:24176:24
3376:0676:06
340:000:00

ZelleFormel
A3=ZÄHLENWENN(E3:AJ3;"TK")*Variablen!$G$2+ZÄHLENWENN(E3:AJ3;"P")*Variablen!$G$3+ZÄHLENWENN(E3:AJ3;"R")*Variablen!$G$5+ZÄHLENWENN(E3:AJ3;"N")*Variablen!$G$4+ZÄHLENWENN(E3:AJ3;"TB")*Variablen!$G$6+ZÄHLENWENN(E3:AJ3;"TBM")*Variablen!$G$7++ZÄHLENWENN(E3:AJ3;"Mash")*Variablen!$G$8+ZÄHLENWENN(E3:AJ3;"VM")*Variablen!$G$9++ZÄHLENWENN(E3:AJ3;"NM")*Variablen!$G$10+ZÄHLENWENN(E3:AJ3;"GT")*Variablen!$G$11+ZÄHLENWENN(E3:AJ3;"7v7")*Variablen!$G$12+ZÄHLENWENN(E3:AJ3;"S")*Variablen!$G$13
B3=SUMMENPRODUKT((E3:AJ3=Variablen!$F$2:$F$12)*(E3:AJ3<>"")*Variablen!$G$2:$G$12)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla
Antwortento top
#4
Hallo,

sehe gerade, dass die Prüfung auf leer wegfallen kann, dann geht es noch etwas kürzer:

Arbeitsblatt mit dem Namen 'Januar'
 AB
358:4884:00

ZelleFormel
A3=ZÄHLENWENN(E3:AJ3;"TK")*Variablen!$G$2+ZÄHLENWENN(E3:AJ3;"P")*Variablen!$G$3+ZÄHLENWENN(E3:AJ3;"R")*Variablen!$G$5+ZÄHLENWENN(E3:AJ3;"N")*Variablen!$G$4+ZÄHLENWENN(E3:AJ3;"TB")*Variablen!$G$6+ZÄHLENWENN(E3:AJ3;"TBM")*Variablen!$G$7++ZÄHLENWENN(E3:AJ3;"Mash")*Variablen!$G$8+ZÄHLENWENN(E3:AJ3;"VM")*Variablen!$G$9++ZÄHLENWENN(E3:AJ3;"NM")*Variablen!$G$10+ZÄHLENWENN(E3:AJ3;"GT")*Variablen!$G$11+ZÄHLENWENN(E3:AJ3;"7v7")*Variablen!$G$12+ZÄHLENWENN(E3:AJ3;"S")*Variablen!$G$13
B3=SUMMENPRODUKT((E3:AJ3=Variablen!$F$2:$F$100)*Variablen!$G$2:$G$100)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß Atilla
Antwortento top
#5
Das wars. Vielen Dank Attila. Du bist genial!

Lieber Gruss

mykophil
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste