Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Arbeitszeitberechnung
#1
Hallo zusammen,


ich benötige ein Sheet um die täglichen Arbeitsstunden zu berechnen.
Ich habe in Spalte A meinen Arbeitsbeginn und in Spalte B mein Arbeitsende.
Die Zellen habe ich hh:mm formatiert, soweit auch kein Problem die Gesamtstunden auszurechnen.

Nun möchte ich in Spalt F Bemerkungen wie "krank" oder "Urlaub" eintragen, sollte an einem Tag ein Eintrag vorhanden sein, soll an diesem Tag die Gesamtarbeitszeit 4 Stunden (keine Pausen berücksichtigen!) betragen.

Wie kann ich das in einer Formel umsetzen?

Danke
Markus
Antwortento top
#2
Hallo,

vielleicht so:

=WENN(ODER(F2="Urlaub";F2="Krank");4/24;REST(B2-A2;1))

oder, wenn es nur darum geht ob in F2 ein Text steht:

=WENN(ISTTEXT(F2);4/24;REST(B2-A2;1))
Gruß
Peter
Antwortento top
#3
(29.03.2015, 16:28)Peter schrieb: =WENN(ISTTEXT(F2);4/24;REST(B2-A2;1))

(29.03.2015, 16:28)Peter schrieb: =WENN(ISTTEXT(F2);4/24;REST(B2-A2;1))

(29.03.2015, 16:28)Peter schrieb: =WENN(ISTTEXT(F2);4/24;REST(B2-A2;1))

Hallo Peter,

die Formel =WENN(ISTTEXT(F2);4/24;REST(B2-A2;1)) ist genau das was ich gesucht habe.
Wenn kein Text eingetragen ist wird ja die Stundenanzahl berechnet, wie muss ich die Formel ändern wenn er 30 Minuten (Pause) abziehen soll.
Bei eingetragenem Text sollen die 30 Minuten nicht abgezogen werden.

Danke
Markus
Antwortento top
#4
Hallo,

ungetestet:

=WENN(ISTTEXT(F2);4/24;REST(B2-A2;1)-2/96)
Gruß
Peter
Antwortento top
#5
Super!

Nur noch eine Kleinigkeit 05 

An den Tagen die noch keine Zeiten enthalten, wirft mir die Formel in der Spalte Gesamtarbeitszeit "########" aus.
Da ich am Ende der Spalte die Gesamtstunden addiere kommt es zu einem Fehler, lässt sich das "######" durch 00:00 ersetzen so dass die Berechnung auch klappt wenn nicht alle Zeiten befüllt sind?
Antwortento top
#6
(29.03.2015, 16:43)Peter schrieb: Hallo,

ungetestet:

=WENN(ISTTEXT(F2);4/24;REST(B2-A2;1)-2/96)

Hallo Peter, ...

http://ms-office-forum.net/forum/showpos...ostcount=8
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#7
Hallo,

danke für die Info - damit hat sich das für mich erledigt.
Gruß
Peter
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste