Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Abfrageproblem
#1
Hallo Leute,

ich verzweifel gerade.

Also ich habe ein Beispiel mal mit hochgeladen...

Ich will die gesammtkosten eines Projektes Berechnen. Ich habe wie zu sehen ist in der 1. Tabelle die Betriebe mit den Mesungen (es wird davon 100'te geben, es soll also jeweils z.B. mit sverweis abgefragt werden), in der 2. sind dann die Zuordnungen. der Betrieb 1 bekommt für alles Meßstellen eine 100'er Nummer, der 2. Betrieb immer die 200'er, die 300'er sind zB. Lager. Wie zu sehen ist natürlich mit unterschiedlichen preisen. Wie kannich jetzt eine Automatische abfrage machen??? Ich bekomme es einfach nicht hin. Hat jemand einen Tip wie ich das am besten bewerkstellige?
Die oberste "Zeile" steht so in der original tabelle fest. Diese kann ich nicht ändern.
Das Lager gibt es nur einmal, steht aber teilweise in Spalte B und C   :s  auch dieses steht fest und kann nicht geändert werden.

So, jetzt bin ich am Ende meiner Weisheit und hoffe auf euch. Wie "bastel" ich am besten die Abfrage?


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 8,9 KB / Downloads: 9)
Antwortento top
#2
Hallo

Ich rate mal:
Code:
=SVERWEIS(B2&C2;Kosten!$B$1:$C$6;2;FALSCH)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Theoretisch ja,... leider gibt es allerdings doppelte Namen... :(

deshalb geht diese abfrage so nicht.
Antwortento top
#4
Hallo,

In Tabelle1 D2:   =INDEX(Kosten!C:C;VERGLEICH(WENN(A2="Betr1";"1"&B2&C2;WENN(A2="Betr2";"2"&B2&C2;"3"&B2&C2));GANZZAHL(Kosten!A:A/100)&Kosten!B:B;0))
Formeleingabe mit Strg  +  Umsch  +  Enter abschließen. Die Formel erscheint dann in geschweiften Klammern.

Du hast allerdings unter 201 und 203 Durchfluß für den gleichen Betrieb mit unterschiedlichen Preisen stehen.
Da wird immer nur der erste Wert gefunden.
ggf. den Namen ändern.
Außerdem muss die Groß - Kleinschreibung passen.

Gruß Günter
[-] Folgende(r) 1 Benutzer sagt Danke an gbr für diesen Beitrag:
  • moviesdown
Antwortento top
#5
Hallo,

Zitat:Außerdem muss die Groß - Kleinschreibung passen.

seit wann das?

Mein Ansatz:

[html]
Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1 Betrieb_1Betrieb_2Kosten
2Betr1Durchfluß 60
3Betr2 Druck55
4Betr2 Duchfluß65
5Betr1Feuchte 70

ZelleFormel
D2=SUMMEWENNS(Kosten!C:C;Kosten!A:A;">="&WENN(B2="";2;1)*100;Kosten!A:A;"<"&WENN(B2="";3;2)*100;Kosten!B:B;B2&C2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
[/html]
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • moviesdown
Antwortento top
#6
Hallo Günter,


darf ich nochmal Stören... von dem Index hab ich so gut wie keine Ahnung und blicke auf die schnelle da auch nicht so durch .:(

Leider funktioniert es nicht. Ich bekomme "Nur" #Wert zurück.

Anbei nochmal meine Excel mit eingefügter Formel.

Danke....


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 9,37 KB / Downloads: 3)
Antwortento top
#7
Hallo Edgar,

sieht soweit gut aus, allerdings scheitert es da mit dem Lager ein bisschen, das wird leider nicht "mitgenommen" :(
Antwortento top
#8
Hallo,

Du hast ja auch kein Lager drin.
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#9
Hallo Edgar,

doch, das Lager wird mal unter Betrieb1 und unter Betrieb 2 geführt (von den Spalten aus). Dort sind die Preise aber gleich (egal ob Betrieb 1 oder 2). Die "zusätzliche info" steht sozusagen in Spalte A.
Antwortento top
#10
Hallo,

und wer blickt die Regeln aus Dir????

So kann man keine Lösung finden!
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste